WP Engine Hosting PHP7 Compatibility Test

WP Engine Hosting PHP7 Compatibility Test

We may earn money or products from the companies mentioned in this post. More information in Affiliate Disclaimer.


WP Engine (WPEngine) HostingUpgrading to PHP 7 can significantly improve the performance of your WordPress web site.

However, it’s important that the plugins and theme in use on your site are PHP 7 ready.

In today’s lesson, you will install a plugin on your WordPress web site, to see if the setup that you currently have passes the PHP 7 tests.

The plugin is made available by the managed WordPress hosting company WP Engine, but it’s designed to work for hosts other than WP Engine as well.

This tool does not upgrade you to PHP 7, it simply suggests whether your site, in its current state, is compatible or not.

WP Engine Hosting Plugin for PHP7This is not an end all be all test, but a very good indicator of PHP 7 compatibility.

To get started installing this PHP checking tool, first login to you WordPress Dashboard.

Click the Plugins menu option to see if you need to perform any plugin upgrades.

Do so if needed unless you have a very good reason for not doing so.

Next, go to Plugins, then Add New.

Do a search for: PHP Compatibility Checker Click Install Now, then Activate.

Under Tools, click on PHP Compatibility.

While, in general, you probably do not want unused plugins and themes on your site, if you do have them and want to keep them, choose the option to Scan all plugins and themes as opposed to just scanning the active ones.

Then click the Scan Site button.

A couple things worth noting here The plugin does not execute any plugin code, so it does not check for runtime PHP 7 compatibility.

For that reason it may indicate everything is fine, but further testing may show otherwise.

Just be certain to browse your site after upgrading.

Sometimes there are false positives as well.

This means that the plugin may indicate a problem when in fact there is not one.

This happens for a variety of reasons.

You can see a list of plugins that may create false positives by clicking the whitelist link.

These include the popular JetPack and WooCommerce plugins.

So, if you have any of these whitelisted plugins installed and get any warnings or errors for them, then you can still follow through with the upgrade to PHP 7.

How you actually upgrade differs from host to host.

If, after the test, you have errors in plugins not on the whitelist, follow the suggestions made by the plugin.

The suggestions may include upgrading to newer versions, or possibly eliminating unneeded plugins, or finding compatible plugins that do the same job.

Once you are comfortable that the plugins and theme used on your web site are compatible with PHP 7, you can initiate an upgrade by contacting technical support.

Fortunately, with WP Engine, they are available around the clock.

First, login to your WP Engine Dashboard at my.wpengine.com.

Make note of the install name you want to do the upgrade for.

To initiate contact, click the Live Chat link at the top right of the screen.

When you hover over it, you will get an indication of the current wait time.

Enter your name and email address.

Choose ‘Other’ from the dropdown box, or if there is something specific to PHP upgrades choose that instead.

Click the Start button.

Once connected, ask for a PHP upgrade for the Install that you did the Compatibility Check with.

That’s it for this lesson.

Leave a Reply